Using ffmpeg via CLI to capture image from QSS301-04L-P4

I noticed that our QSS301-04L-P4 Security NVR has an RTSP service. I thought if it would be easy enough to access the live stream via RTSP and capture an image.

Turns out, it’s not that difficult and can be performed using ffmpeg. Once you have ffmpeg binary available for your platform, execute it like so.

ffmpeg -y -i rtsp://username:password@192.168.nn.nn:554/unicast/c1/s0/live -vframes 1 image-capture.jpg

The above example will capture image from c1 (Channel 1) and s0 (Stream 0 = main high resolution stream).

Commvault 11 – Commserve DR Backup

To use Commcell Console Send Log Files feature to collect/generate a Commserve DR Backup. All you need to do is follow the following simple steps.

Logon to Commcell Console and right click the Commserve client object, select All Tasks and Send Log Files (as shown below).

When the dialog displays, in the Computers tab, tick/select CommServe object (as shown below).

Select Commcell Information tab and tick/select the Commserve Database Option and Get Latest Database(s) Option (as shown below).

In Output tab, select the options appropriate for your environment. (example shown below).If your unsure if you can upload directly via HTTPS, best to unselect this option and save the output to a Local Path, which will be on the Commserve. Which when completed will allow you to collect the file generated and manually upload to Commvault Support Portal (or via FTP).

If you find this information valuable, please provide a comment.

Setting up Mikrotik RouterBoard with USB Mobile Broadband Dongle

On the account I won a Mikrotik hAP-2nD from Duxtel, see post here. I thought it might be a good idea to see if I could get this unit to work with a Telstra 4G USB Mobile Broadband Dongle.

Initially I had some problems, however, you shouldn’t do things when tired. Eventually I worked out where I had went wrong and got things to work after all.

First I had to set the following in Winbox Terminal;

/port firmware set directory=firmware ignore-directip-modem=yes

After I reboot the router, my device showed up as being connected to USB1. Which is what is needed for the next step.

Mikrotik should configure a PPP interface automatically, as such you will need to tweak it to match what your needs are. Those settings below are what I am using for my Telstra dongle in question. I modified the name of my interface to suit my environment.

name="ppp-out2" max-mtu=1500 max-mru=1500 mrru=disabled port=usb1 
      data-channel=3 info-channel=2 apn="telstra.internet" pin="" user="" 
      password="" profile=default phone="" dial-command="ATDT" modem-init="" 
      null-modem=no dial-on-demand=yes add-default-route=yes 
      default-route-distance=0 use-peer-dns=yes keepalive-timeout=30 
      allow=pap,chap,mschap1,mschap2

Finally step was to setup a NAT rule to use the new out interface.

/ip firewall nat
add action=masquerade chain=srcnat comment="masquerade for ppp-out2 (dongle)" 
    out-interface=ppp-out2

Once this was all done, it worked fine. Very impressed.

Unit pictured below configured and running with Telstra 4G dongle plugged in.

Duxtel Mikrotik Monday Hardware Arrives

The #mikrotikmonday hardware I won from Duxtel arrived yesterday, however I wasn’t able to make it to post office until today.

Still very happy with the win of this router, it will certainly come in handy for something I want to perform.

This will give me the opportunity to configure the USB port with a Mobile Broadband Dongle and understand how to configure it. Without messing up my own existing Mikrotik RouterBoard which I use for my internet connectivity already.

 

Commvault – Demo of using FTP to upload items onto qnftp01 site

When it comes to uploading via FTP to the Commvault support site (qnftp01), it seems the most common problem people face is confusion when they see a directory listing that contains nothing.

I created this video clip several months ago, as it’s a quick reference for someone to watch and to understand why the directory is empty and how to manually change into the blind directory.

The video clip has helped a great deal so far, so I thought I should publish it here on my blog.

Remember to watch the HD version, so you can see what is on the screen.

Just remember the CCID is unique to every installation/deployment of Simpana, so use your one, not the one in the video.

Of course, if FTP is not allowed outbound in most corporate sites, so in those situations, it is recommended to use the Commvault – Maintenance Advantage Portal (http://ma.commvault.com/) and the HTTP Log upload feature on the site.

Simpana 10 – Commserve DR Backup

A demo I put together that shows how to perform a Commserve DR Backup in Simpana 10. It talks about the process of how to do it manually and where you can find the files associated with the process. Sometimes this might need to be performed manually and collected manually so that you can upload it via some manual process due to lack of connectivity in an environment to the outside world. i.e. internet.

It’s a follow on from a previous post that talks about the same process in Simpana 9. Which you can find here.

Hope you enjoy the demo. If this post helps you, please leave a comment.